Fix Obtaining IP Address / WiFi Disabled Android Problem

Usually there would be no problems when you connect WiFi connections on your android smartphones, it connects almost instantly when you turn the WiFi on. But there are situation when sometimes it will stuck on ‘Obtaining IP address..’ when you look at the WiFi settings page. After few moments, for some users it might get connected and a message ” WiFi Disabled” will be the result for other users. This post discuss the solution to this problem and describes how to get connected easily.

obtaing IP address

Usually this happens to smartphones after firmware upgrades, changes in WiFi router configurations etc. When you turn on the WiFi it scans for WiFi, obtains IP address then disconnect. ¬†After researching throughout to find a possible work around for this issue, I’ve found a simple solution to get instant WiFi connection. All you have to do is use the static IP option.

use static IP

  • On your android device,¬†goto Settings > Wireless and networks > WiFi Settings > tap advanced from when you press left menu button.
  • You”ll be there in a page where you can set the regulatory domain, sleep policy and static IP. Just enable the ” Use static IP” option. Then enter the following entries in their respective fields.

IP address : 192.168.1.253
Gateway: 192.168.1.1
Netmask: 255.255.255.0
Dns1: 8.8.4.4

 

  • After doing this, click save. Then try to reconnect the WiFi, for me it get connects immediately. I’ve tested this with my BSNL home WiFi router from Teracom. You have to do this only once and no need to re-enter the fields every time when you connects to a new network. If you have any difficulties in connecting to other networks, like a free public WiFi, disable static IP option and check to see if it works.

 

Share this article:

Comments (5)

  1. yes it works 100%

  2. sir i am using moto g with android version 4.4.2..it is not connecting to my bsnl teracom wifi..and there is no option for like use static ip in its wi fi setting.suggest me something.thank you.

  3. it’s worked for me, thanks a lot.

  4. It worked on my moto g2. thanks!

    1. moto g3 v6.0.1 (pure stock)

      after apllying these settings it get connected but after 1sec it disconnected nd “connected-disconnected” process continuing.. didn’t worked for me. help me out if u can.

Leave a Reply to vivek Cancel reply

Your email address will not be published. Required fields are marked *